Приложения, которые не будут работать на macOS 10.15 Catalina

0
37

Заранее узнайте, какие приложения не будут работать после обновления до macOS Catalina. Проверьте, не возникнут ли у вас проблемы после обновления операционной системы.

Содержание
Почему 32-разрядные приложения не поддерживаются macOS Catalina? Как проверить, будут ли приложения работать на macOS Catalina? Что делать, если приложение не работает на macOS Catalina? Какие приложения не будут совместимы с macOS Catalina? Приложения от Apple, которые не будут работать в macOS Catalina Aperture Office Suite iWorks Final Cut Pro и Logic Studio Приложения Microsoft, которые не будут работать в macOS Catalina Приложения Adobe, которые не будут работать в macOS Иллюстратор Catalina Photoshop InDesign Acrobat Pro Lightroom Premiere Pro After Effects Games Aspyr это не сработает в macOS Catalina Что я могу сделать, чтобы мои приложения работали?

Этой осенью Apple выпустит следующую пятнадцатую версию MacOS для Mac. Последний выпуск, также известный как macOS Catalina , принесет одно очень важное изменение с точки зрения пользователей , которое может быть незаметным на первый взгляд, но удивит вас в самый неожиданный момент. После обновления будут проблемы со старым программным обеспечением и драйверами для более старых периферийных устройств, таких как принтеры, мыши и клавиатуры.

Источник: Apple

В этой статье мы рассмотрим приложения, которые не совместимы с последней версией MacOS Catalina . Некоторые из этих приложений больше не работают с MacOS 10.14 Mojave, но этой осенью будет гораздо больше несовместимых приложений, чем раньше.

Если вам интересно, совместим ли ваш компьютер с последней версией системы, проверьте это в нашей статье . Если вы хотите узнать, что нового в последней версии MacOS Catalina, вы можете проверить это здесь .

Если ваш Mac выпущен до 2012 года, вы не сможете перейти на Catalina, но если ваш Mac достаточно старый, чтобы вы могли подумать о его замене, вы должны знать, что он может поставляться с установленным MacOS Каталина. Указывает, что программное обеспечение, над которым вы сейчас работаете, может не работать, если вы обновитесь до более новой версии.

Старые версии приложений, выпущенные даже самыми известными компаниями, такими как Adobe , Microsoft и даже сама Apple , станут неподдерживаемыми. Большинство из тех программ, которые не совместимы, являются старыми версиями, выпущенными несколько лет назад . Однако существует большое количество пользователей, которые используют их, потому что они не используют их время от времени, не используют свои функции полностью или не хотят платить за подписку на последние версии.

Многие пользователи столкнулись с проблемой запуска Photoshop CS5 на MacOS Mojave, выпущенной в 2018 году. Эта проблема была решена, и более старая версия графической программы прекрасно работает на macOS 10.14 , но мы подозреваем, что она больше не будет работать на macOS 10.15 Catalina.

Уже во время обновления до Mojave многие программы не хотели работать должным образом, но после обновления до Catalina ситуация будет еще хуже , потому что в Mojave старые программы могут быть вынуждены работать. Новая система имеет измененную архитектуру, благодаря которой невозможно будет запускать 32-разрядное программное обеспечение.

Почему 32-разрядные приложения не поддерживаются macOS Catalina?

Apple подготовила специальный веб-сайт , который объясняет, почему поддержка 32-битных приложений в последней версии macOS Catalina была прекращена . Apple считает, что это старое программное обеспечение не обеспечивает такого же удобства работы пользователей, как новые версии, а также может замедлить работу вашего Mac.

Компания объясняет, что более новые 64-разрядные приложения имеют доступ к большему объему памяти , благодаря чему они могут повысить производительность во время работы.

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Macworld

Напоминаем, что это не первый случай, когда Apple отказывается от поддержки 32-битных приложений . IOS не поддерживает их с 2017 года , когда была запущена iOS 11 . Эта система поддерживает только 64-битные приложения и устройства с процессорами Apple A7 (первая 64-битная система для мобильных устройств) и новее. Теперь, как вы можете видеть, пришло время отказаться от поддержки 32-битных приложений на компьютерах.

Как проверить, будут ли приложения работать на macOS Catalina?

macOS 10.15 Catalina больше не позволяет запускать 32-битное программное обеспечение . По этой причине первое, что вы должны сделать, это проверить, используете ли вы 32-разрядное приложение и очень ли оно важно для вас. Стоит сделать это перед обновлением до macOS Catalina, чтобы не разочароваться.

Вот как определить 32-битные приложения в macOS:

  • Нажмите на логотип Apple в строке состояния в левом верхнем углу экрана.
  • Выберите этот Mac …
  • Перейти к системному отчету
  • Нажмите на Программное обеспечение> Приложения

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Macworld

Проверьте, указано ли используемое программное обеспечение как 64-разрядное . Вы можете отсортировать список по этому столбцу, чтобы увидеть в начале все приложения, которые не будут поддерживаться в macOS 10.15 Catalina (если у вас есть).

Также обратите внимание на происхождение приложения. Если вы обнаружите в столбце «Получено от», что программа принадлежит зарегистрированному разработчику , Mac App Store или Apple , вам не о чем беспокоиться. Однако у вас могут возникнуть проблемы, когда вы найдете информацию о неизвестном происхождении в этой области. Это может вызвать проблемы с совместимостью в будущем.

Что делать, если приложение не работает на macOS Catalina?

Если приложение, которое вы регулярно используете, не будет поддерживаться после обновления до MacOS 10.15 Catalina, у вас есть несколько вариантов на выбор:

Обновление до новой версии . Вероятно, разработчик обновил приложение, чтобы оно стало 64-разрядным и соответствовало всем остальным требованиям Apple. Вам, вероятно, придется признать, что вам придется заплатить за обновление . Возможно, вам придется немного изменить свои привычки . Если приложение не было обновлено, вам нужно искать замену .

Если программист приложения не обновил его или, возможно, прекратил его дальнейшую разработку, вы можете найти альтернативное приложение, которое будет работать на Mac с MacOS Catalina.

Другое решение — воздержаться от обновления . Эта опция будет доступна только на компьютерах, которые уже были изготовлены и проданы. Если вы купите копию с предустановленной MacOS 10.15 Catalina, вы не сможете использовать 32-битные приложения и не сможете перейти на Mojave. Также помните, что Apple, вероятно, захочет прекратить поддержку Mojave как можно скорее . Это последняя система с поддержкой 32-битных приложений , которые не приветствуются в Купертино. Возможно, что в 2020 году Мохаве прекратит получать патчи безопасности. Этот факт в некоторой степени подтверждает информацию о том, что все компьютеры (кроме Mac Pro 2012 года), которые могут быть обновлены до Mojave, также совместимы с macOS Catalina .

Менее удобное, но возможное решение — установить две версии операционной системы на одном компьютере . Вы можете обновить свой компьютер до Catalina и рядом с отдельным разделом или диском (если у вас есть компьютер с возможностью установки двух дисков), чтобы установить более старую версию macOS Mojave, чтобы вы могли продолжать использовать более старые программы.

Вам также нужно знать, что Apple не прекратит поддержку 32-битных приложений в одночасье , компания уже несколько лет предупреждает разработчиков и призывает их писать 64-битные программы . Разработчики, у которых еще нет 64-битных версий своих приложений, скорее всего, будут работать над миграцией. Если они этого не делают, пришло время подумать о переходе на более современное приложение. Каждому программисту, который еще не обновил свое приложение, не хватает времени . Мы предполагаем, что если приложение до сих пор не обновлялось, его разработка, вероятно, была прекращена.

С другой стороны, большинство 32-битных приложений имеют более новые 64-битные версии . Вполне вероятно, что разработчики будут рекомендовать вам обновить их. Это в основном относится к популярным программам, которые используются многими людьми.

Какие приложения не будут совместимы с macOS Catalina?

Вот некоторые из наиболее известных и популярных приложений, которые вам нужно будет обновить перед установкой macOS 10.15 Catalina:

  • Adobe Illustrator CS5
  • Abobe InDesign CS5 и CS6
  • Apple Aperture
  • Microsoft Excel 2011
  • Microsoft PowerPoint 2011
  • Microsoft Outlook 2011
  • Microsoft Word 2011

Как видите, в список включены более старые версии популярных программ . Даже если вы используете 64-битную версию вышеупомянутых программ, вы не пропустите некоторые неудобства. Вы также можете попробовать программы с дополнениями и плагинами . Может оказаться, что само приложение является 64-битным, но дополнения к нему были написаны как 32-битные приложения.

Приложения Apple, которые не будут работать на macOS Catalina

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Macworld

В случае совместимости со старыми программами проблема также относится к самой Apple , которая имеет некоторые старые версии программ, которые в настоящее время не разрабатываются, и у которых все еще есть много пользователей.

В фильмах Apple Movie , Final Cut Pro и Motion могут быть проблемы с несовместимыми носителями. Это связано с тем, что для создания этих мультимедийных файлов могли использоваться более старые форматы или кодеки. Вы должны быть в состоянии преобразовать эти файлы в H.264 в iMovie или Final Cut Pro.

апертура

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Apple

Если вы используете последнюю версию Aparture 3, выпущенную в 2010 году, вы можете подумать, что проблемы вас не касаются, поскольку приложение является 64-разрядным. К сожалению, это не так. Apple завершила разработку этой программы в 2014 году , и на странице технической поддержки вы найдете информацию о том, что программа не будет поддерживаться в операционных системах, более новых, чем macOS Mojave. Apple рекомендует перейти на приложение « Фотографии» или приобрести Adobe Lightroom .

IWorks офисный пакет

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Apple

Если вы все еще используете более старые версии приложения Apple для iWorkPages , Keynote и Numbers , возможно, вам потребуется обновить.

Все приложения iWork ’09 (с 2009 года) являются 32-разрядными . Это может быть проблемой для тех пользователей Mac, которые предпочитают эти старые версии этих приложений перед современными аналогами.

Первый офисный пакет iWork, включающий 64-битную версию, — это iWork 2013 .

Если у вас есть офисный пакет iWork ’09, вы должны обновить его до последней версии. К счастью, все три программы были бесплатными с 2017 года, и вы найдете их в Mac App Store .

Final Cut Pro и Студия Логики

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Apple

Final Cut Pro и Logic Studio были преобразованы в Final Cut Pro X и Logic Pro X в 2011 году. Если вы все еще используете старую версию программного обеспечения, обратите внимание, что сопутствующие приложения, такие как DVD Studio Pro, Soundtrack Pro, Color и Cinema Tools, больше не совместимы с системами High Sierra или Mojave .

Если вы хотите продолжить использовать эти программы, вы должны обновить их или прекратить обновление системы и остаться на старой версии macOS.

Приложения Microsoft, которые не будут работать в macOS Catalina

Если вы все еще используете приложение Microsoft Office для Mac 2011 (Word 2011, Excel 2011, PowerPoint 2011 и Outlook 2011 включены в пакет), возможно, вы захотите выполнить обновление.

Версия 2011 года состоит только из 32-разрядных приложений , и Microsoft отказалась от поддержки этой версии в 2017 году.

Неподдерживаемые приложения:

  • Word 2011
  • Excel 2011
  • PowerPoint 2011
  • Outlook 2011

Office 2016 в начале также не состоял из 64-разрядных приложений, но во время обновления до версии 15.25, которое появилось в августе 2016 г., 64-разрядные приложения заменили более старые 32-разрядные аналоги. Если вы активно используете Office 2016 или у вас есть подписка на Office 365 , вы уже получили это обновление. Если этого не произошло, вы можете легко установить его по этой ссылке .

Все новые версии Office и Office 365 полностью совместимы с macOS Catalina . Чтобы быть уверенным, вы все равно можете вручную проверить наличие обновлений перед началом процесса установки новой системы.

Если вы используете Office 2011 для Mac, самое время подумать об обновлении . Вы также можете установить бесплатную версию Apple iWorks Suite. Вы можете найти его в Mac App Store. Офисный пакет от Apple полностью совместим с файлами Office.

Приложения Adobe, которые не будут работать на MacOS Catalina

Adobe начала переход на 64-битные приложения еще в 2008 году , но некоторые пользователи Mac по-прежнему используют старые версии, которые не будут поддерживаться в Catalina. Основной причиной отсутствия обновлений, вероятно, является переход компании на модель продаж по подписке, которую компания представила в 2011 году в Creative Cloud .

Adobe опубликовала блог, в котором перечислены все известные проблемы с ее продуктами в Мохаве, и, вероятно, будет делать то же самое для Catalina при запуске обновления этой операционной системы. Вы можете найти больше информации здесь .

Если вы все еще используете старые приложения и не обновили приложение до Creative Cloud, вам может потребоваться это сделать.

Photoshop

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Adobe

Для Photoshop Adobe четко указывает, что рекомендует использовать последнюю доступную версию этой графической программы . У многих пользователей были проблемы с установкой старых версий Photoshop CS5 на компьютеры с MacOS Mojave.

Тем не менее, это не единственная версия Photoshop, которая имела проблемы в Мохаве. Были проблемы с совместимостью с Photoshop 2018 и более ранними версиями. Adobe рекомендует пользователям обновить до Photoshop CC 2019 .

иллюстратор

Иллюстратор CS5 является 32-разрядным , поэтому он, конечно, не работает в Каталине . Версия CS6 Illustrator, выпущенная в 2012 году, добавила 64-разрядную поддержку, поэтому, если вы используете Illustrator CS6 или более позднюю версию, вам не следует беспокоиться о ее совместимости с новой системой.

InDesign

InDesgin из пакета CS5 — это еще одно приложение, которое перестает работать после обновления до macOS 10.15 Catalina . InDesign не обновлялся до 64-разрядной версии, пока не была выпущена версия CC, поэтому даже версия CS6 не будет работать на компьютере с последней версией macOS .

Даже у текущей версии были некоторые проблемы с работой на MacOS Mojave. Есть проблемы с темным режимом и исчезновение курсора.

Акробат Про

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Adobe

Acrobat Pro версии 9.5.5 — это еще одно 32-разрядное приложение от Adobe, которое не будет работать вместе с macOS Catalina. Даже более новые Acrobat DC и Acrobat DC Reader, вероятно, имели проблемы на Mac, вызванные некоторыми 32-разрядными компонентами. Мы надеемся, что Adobe сможет решить проблемы, с которыми сталкивается Acrobat, до выпуска macOS Catalina.

Lightroom

Lightroom является 64-битным с момента появления Lightroom 2 в 2008 году , поэтому у вас, вероятно, не будет проблем с совместимостью с этой программой. Единственная проблема Lightroom — автоматическое переключение в темный режим. Мы надеемся, что это обновление будет исправлено с помощью Catalina.

Премьера Про

Premiere Pro является 64-разрядным с 2008 года, когда Adobe представила Premiere Pro CS4, поэтому есть большая вероятность, что вы используете более новую версию. Проблемы, с которыми сталкивается Premiere Pro, включают ошибку доступа к микрофону и камере, когда темный режим не работает должным образом.

After Effects

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Adobe

After Effects является 64-разрядной с момента выпуска версии CS5 в 2010 году.

Aspyr игры, которые не будут работать на macOS Catalina

Разработчик игры Aspyr подтвердил, что он прекратит продавать 32-битные игры, потому что они не будут работать на компьютерах с установленной MacOS 10.15 Catalina.

Представители компании также отметили, что многие из предлагаемых названий уже являются 64-битными или будут обновлены до сентября, чтобы они без проблем работали на macOS 10.15 Catalina.

Приложения, которые не будут работать на macOS 10.15 Catalina

Источник: Adobe

Следующие 32-битные игры будут удалены из библиотеки Aspyr:

  • Borderlands: предварительное продолжение
  • Call of Duty
  • Call of Duty 2
  • Call of Duty 4
  • Call of Duty Black Ops
  • Call of Duty Modern Warfare 2
  • Цивилизация IV
  • Цивилизация IV: колонизация
  • Doom 3
  • Duke Nukem Forever
  • Фаренгейт
  • Homeworld Remastered Collection
  • добыча
  • Quake 4
  • RAGE
  • Звездные войны: Империя в войне
  • Звездные войны: Академия джедаев
  • Звездные войны: джедай изгой
  • Звездные войны: сила развязана
  • Sims 2: Истории из жизни
  • Sims 2: Истории питомцев
  • Sims 2: истории о побегах
  • Расхитительница гробниц 2

Что я могу сделать, чтобы мои приложения работали?

Хотите знать, что вы можете сделать, чтобы ваши приложения не работали в 2019 году?

Вот наши советы:

  • Свяжитесь с создателем приложения, если вы не уверены, будет ли приложение, которое вы используете, работать с последней версией MacOS Catalina.
  • Не обновляйте до версии 10.15 Catalina, пока вы не будете уверены, что все ваши приложения продолжат работать.
  • Рассмотрите возможность обновления вашего программного обеспечения или ищите замены с аналогичной или даже большей совместимостью.